[nSLUG] SSH - Dropped connections

Bill Davidson bill at supercity.ns.ca
Fri Jan 16 16:53:52 AST 2004


Hi:

When we got a new connection here in our office, I was losing my ssh 
connections to our server all the time.  I changed a few settings (on the 
servers and the client) and thins improved a lot:

~# cat /proc/sys/net/ipv4/tcp_keepalive_intvl 
15
~# cat /proc/sys/net/ipv4/tcp_keepalive_probes 
1
~# cat /proc/sys/net/ipv4/tcp_keepalive_time
300

Still lose a few connections, but not nearly as frequently.

On January 16, 2004 10:44 am, David L. Potter wrote:
> I have two machines which are both running RedHat 7.2 with
> OpenSSH_3.1p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
>
> One machine is on the GT network and the other machine is local (inside
> a SMC router/firewall.
>
> Both machines were using a standard configuration (with KeepAlive), and
> I'm using the same ssh client to access both machines.
>
> The remote machine has always (consistently) dropped idle connections on
> the client end - with the bash and ssh processes remaining alive on the
> server end.
>
> The local machine (same server configuration) and the Chebucto sshd
> server have never dropped connections like this - same client.
>
> This has finally got very irritating... ;-)
>
> Fire away folks... ;-) I'm going out to cool dawn... ;-)
>
> david potter
>
>
>
>
>
>
> _______________________________________________
> nSLUG mailing list
> nSLUG at nslug.ns.ca
> http://nslug.ns.ca/cgi-bin/mailman/listinfo/nslug

-- 
Bill Davidson
Systems Administrator
Supercity Internet Services




More information about the nSLUG mailing list