[nSLUG] Mandrake 9.0 same problem

Donald Teed dteed at artistic.ca
Fri Mar 21 15:08:37 AST 2003

On Fri, 21 Mar 2003, [ISO8859_1] Réjean Chamberland wrote:

> > What is the error when you run startx?
> >
> The error message is different than it was when I tried to install Mandrake 8.0. In Mandrake 9.0 it says:
> xauth: error while loading shared library: libXmuu.so.1: cannot open shared object file: No such file or directory

Hmmm.  That means a dependancy failed.  Whatever application you were
running (Xfdrake or startx?) called on some program which required the
libXmuu.so.1 library.  A good linux installer will make sure this
sort of thing won't happen via dependancy checking.  I have no
idea how good that is in Mandrake.  Of course, the installer checkers will
usually recommend the combinations of packages that will make all
applications happy - the user usually has an option to ignore
those hints or recommendations and install package A without library B.

Whether it is a bug in the installer, or improper selections by the
installer operator, you'll need to find the package that provides
this library and install it.  I don't know what the
package management is like in Mandrake.  If it is RPM based I can
give you some hints on how to install it once you have found the package.

The package should have a name like XFree86-libs-4.3-{something}
It should be on the Mandrake CDROMs somewhere.

> None of the combinations has worked. Whenever I do an installation the computer crashes wether I agree for the X configuration to be tested or not.Same thing when I use XFdrake.

Does the application crap out with the libXmuu.so.1 error or do you
mean the machine goes down completely and reboots?

>         - Disable the resolution using the "#" at ModeLine.
>           And after you select the monitor model in your install diskette, copy the data of ModeLine to XF86Config.  
> Any suggestion will be appreciated! 

Your current error suggests this is broken due to missing library
file(s).  Don't get into hand tweaking your XF86Config until
it is appropriate (X runs, but shows error about no matching

More information about the nSLUG mailing list