[nSLUG] Redhat 8, Dell Dimension L500r, RTL8139

Donald Teed dteed at artistic.ca
Tue Mar 11 07:13:38 AST 2003

Sometimes Redhat can add the entry for the alias for the ethernet
device, other times it needs help.

Look in your boot up messages with dmesg for hints of any
matching device driver you should be maping to eth0 or

Suppose you see devices tulip and ne2k-pci identified
in the dmesg (boot up messages that sometimes flash by
too quickly) then you make sure you have entries like
this in your /etc/modules.conf

alias eth0 tulip
alias eth1 ne2k-pci

Note: it is the chipset not the card brand and model that counts),

If you saw rtl8139 mentioned in the dmesg output, then use that:

alias eth0 rtl8139

I think you might need the tulip driver if it like the one I have.
Go by the dmesg output - that is your hint as to what the device
identified itself as to Linux kernel probes.

Then you must also configure /etc/sysconfig/network-scripts/ifcfg-eth0
to assign IP, or tell it to use DHCP.  I'm not sure what
the problem is when you say "it doesn't work" - there are
many outcomes that fit into that bracket.

--Donald Teed

On Tue, 11 Mar 2003, Dean Landry wrote:

> Hello,
> I've just received a new-to-me computer so I decided to install Redhat 8 on it.  Redhat didn't automatically install my NIC so I tried Mandrake 9.  It didn't work either.  So I've gone back to Redhat 8.  I did a minimal install.  When try to 'modprobe 8139too' I get this message in the syslog:
> 8139too Fast Ethernet driver 0.9.25
> Mar 11 01:10:22 localhost kernel: PCI: Found IRQ 9 for device 01:09.0
> Mar 11 01:10:22 localhost kernel: PCI: Sharing IRQ 9 with 00:1f.3
> Mar 11 01:10:22 localhost kernel: 8139too: 01:09.0: region #1 not an MMIO resource, aborting
> Mar 11 01:10:22 localhost kernel: Trying to free nonexistent resource <fa700000-fa70000f>
> Mar 11 01:10:22 localhost kernel: Trying to free nonexistent resource <fa700100-fa7001ff>
> Any ideas how to troubleshoot this?  I've tried another one of these cards with the same error.  I also tried a RTL8029 card with the same effect.  
> Thanks in advance for any assitance.
> Dean

More information about the nSLUG mailing list